مهمان گرامی، خوش‌آمدید!
شما قبل از این که بتوانید در این انجمن مطلبی ارسال کنید باید ثبت نام کنید.

نام کاربری
  

گذرواژه‌
  





جستجوی انجمن‌ها

(جستجوی پیشرفته)

آمار انجمن
» اعضا: 120
» آخرین عضو: m_mhd
» موضوعات انجمن: 6
» ارسال‌های انجمن: 6

آمار کامل

کاربران آنلاین
در حال حاضر 9 کاربر آنلاین وجود دارد.
» 0 عضو | 9 مهمان

آخرین موضوع‌ها
معرفی NTP Server
انجمن: ویندوز سرور
آخرین ارسال توسط: saeed
2018/03/17، 05:10 AM
» پاسخ: 0
» بازدید: 714
PPTP-Mikrotik
انجمن: آموزش ها
آخرین ارسال توسط: sina
2018/02/19، 09:44 AM
» پاسخ: 0
» بازدید: 731
Linux Tunnel
انجمن: لینوکس Linux
آخرین ارسال توسط: sina
2018/02/19، 09:40 AM
» پاسخ: 0
» بازدید: 692
Mikroitk-Tunnel
انجمن: آموزش ها
آخرین ارسال توسط: sina
2018/02/19، 08:23 AM
» پاسخ: 0
» بازدید: 704
راه اندازی Web Analyzer د...
انجمن: آموزش ها
آخرین ارسال توسط: sina
2018/02/18، 06:02 PM
» پاسخ: 0
» بازدید: 1,676
آموزش نصب IBSng A1.24
انجمن: آموزش ها
آخرین ارسال توسط: sina
2018/02/17، 09:24 AM
» پاسخ: 0
» بازدید: 1,482

 
  معرفی NTP Server
ارسال کننده: saeed - 2018/03/17، 05:10 AM - انجمن: ویندوز سرور - بدون پاسخ

در حالت عادی تمام کلاینت های دامین ساعت خود را با دامین کنترلر همگام میکنند
برای معرفی NTP Server برای ویندوز سرور یا کلاینتهایی که عضو دامین نیستند از این دستور می توان استفاده کرد

w32tm /config /manualpeerlist:"NTP SERVER IP" /syncfromflags:manual /reliable:yes /update

چاپ این مطلب

  PPTP-Mikrotik
ارسال کننده: sina - 2018/02/19، 09:44 AM - انجمن: آموزش ها - بدون پاسخ

برای استفاده از Mikrotik به عنوان VPN ras مراحل زیر را انجام می دهیم:
config کردن Mikrotik به عنوان VPN سرور
برای این کار از دستورات زیر استفاده می کنیم:

کد:
/interface pptp-server server set enabled=yes max-mtu=1488 max-mru=1488 authentication=chap,mschap1,mschap2,pap keepalive-timeout=10 default-profile=default
/ppp profile set 0 local-address=<Mikrotik ip address> change-tcp-mss=yes
/ip firewall mangle add chain=forward action=change-mss new-mss=1300 tcp-flags=syn protocol=tcp


config کردن Mikrotik برای ارتباط با IBSng
این کار با دستورات زیر انجام می شود:

کد:
/ppp aaa set use-radius=yes accounting=yes interim-update=60
/radius add address="IBSng server IP" accounting-port=1813 authentication-port=1812 secret="prefered secret" service=ppp,  timeout=1000
/radius incoming set accept=yes
/radius incoming set port=1700


تنظیم routing ها
NAT کردن ip های assign شده به user ها:
کد:
iptables -t nat -A POSTROUTING -s <IP range> -j MASQUERADE


تنظیم route برگشت:
کد:
route add -net <IP range> gw <Mikrotik's IP>

چاپ این مطلب

  Linux Tunnel
ارسال کننده: sina - 2018/02/19، 09:40 AM - انجمن: لینوکس Linux - بدون پاسخ

تانل چیست
ایجاد ارتباط ما بین بخش های مختلف شبکه بعضا با محدودیت هایی مواجه است که جهت رفع برخی از آن و یا ساده تر کردن تنظیمات انجام شده می توان از تکنولوژی های Tunneling استفاده کرد. این تکنولوژی ها امکان یک مسیر مطمین بین دو نقطه از شبکه، ساده تر کردن تنظیمات مسیریابی ( Routing ) و بعضا امن تر کردن مسیر ترافیک عبوری را فراهم خواهند کرد. تانل ipip یکی از این تکنولوژی ها بوده که امکان اتصال دو نقطه از شبکه را تنها در قالب Encapsulation فراهم می کند. این تکنولوژی به دلیل over-head کمی که به شبکه تحمیل می کند بیشتر مورد استفاده قرار می گیرد.

راه اندازی ipip-Tunnel بر روی Linux-Server


راه اندازی تانل ipip درلینوکس
با توجه به شکل زیر میخواهیم ارتباط دو Linux-Server را از طریق ipip-tunnel برقرار کنیم .
[تصویر:  Linux_ipip_1.png]
تنظیمات Linux-Server شماره ۱ :

کد:
ip tunnel add ipip-Tunnel  mode ipip remote 20.0.0.2  local 20.0.0.1


ست کردن ip در سر تانل :
کد:
ifconfig ipip-Tunnel 10.0.0.1/24  


کانفیگ Linux-Server شماره 2 :
کد:
ip tunnel add ipip-Tunnel  mode ipip remote 20.0.0.1  local 20.0.0.2


ست کردن ip در سر تانل :
کد:
ifconfig ipip-Tunnel 10.0.0.2/24



مشاهده وضعیت Ipip-Tunnel :

کد:
ip tunnel show
ipip-Tunnel: ip/ip  remote 20.0.0.2  local 20.0.0.1  ttl inherit



مشاهده ip address بر روی ipip-tunnel :

کد:
ifconfig ipip-Tunnel
ipip-Tunnel Link encap:UNSPEC  HWaddr 14-00-00-01-00-00-C0-E7-00-00-00-00-00-00-00-00  
inet addr:10.0.0.1  P-t-P:10.0.0.1  Mask:255.255.255.0
inet6 addr: fe80::200:5efe:1400:1/64 Scope:Link
UP POINTOPOINT RUNNING NOARP  MTU:1476  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:2 dropped:0 overruns:0 carrier:2
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


راه اندازی تانل gre درلینوکس
با توجه به شکل زیر میخواهیم ارتباط دو Linux-Server را از طریق gre-tunnel برقرار کنیم .
[تصویر:  Linux_gre_1.png]
تنظیمات Linux-Server شماره ۱ :
کد:
ip tunnel add Gre-Tunnel  mode Gre remote 20.0.0.2  local 20.0.0.1


ست کردن ip در سر تانل :
کد:
ifconfig Gre-Tunnel 10.0.0.1/24


کانفیگ Linux-Server شماره 2 :
کد:
ip tunnel add Gre-Tunnel  mode Gre remote 20.0.0.1  local 20.0.0.2


ست کردن ip در سر تانل :
کد:
ifconfig Gre-Tunnel 10.0.0.2/24



مشاهده وضعیت Gre-Tunnel :

کد:
ip tunnel show
ipip-Tunnel: ip/ip  remote 20.0.0.2  local 20.0.0.1  ttl inherit



مشاهده ip address بر روی gre-tunnel :

کد:
ifconfig Gre-Tunnel  
Gre-Tunnel Link encap:UNSPEC  HWaddr 14-00-00-01-00-00-C0-E7-00-00-00-00-00-00-00-00  
inet addr:10.0.0.1  P-t-P:10.0.0.1  Mask:255.255.255.0
inet6 addr: fe80::200:5efe:1400:1/64 Scope:Link
UP POINTOPOINT RUNNING NOARP  MTU:1476  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:2 dropped:0 overruns:0 carrier:2
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

چاپ این مطلب

  Mikroitk-Tunnel
ارسال کننده: sina - 2018/02/19، 08:23 AM - انجمن: آموزش ها - بدون پاسخ

تانل چیست
ایجاد ارتباط ما بین بخش های مختلف شبکه بعضا با محدودیت هایی مواجه است که جهت رفع برخی از آن و یا ساده تر کردن تنظیمات انجام شده می توان از تکنولوژی های Tunneling استفاده کرد. این تکنولوژی ها امکان یک مسیر مطمین بین دو نقطه از شبکه، ساده تر کردن تنظیمات مسیریابی ( Routing ) و بعضا امن تر کردن مسیر ترافیک عبوری را فراهم خواهند کرد. تانل ipip یکی از این تکنولوژی ها بوده که امکان اتصال دو نقطه از شبکه را تنها در قالب Encapsulation فراهم می کند. این تکنولوژی به دلیل over-head کمی که به شبکه تحمیل می کند بیشتر مورد استفاده قرار می گیرد.



راه اندازی تانل ipip در میکروتیک
با توجه به شکل زیر میخواهیم ارتباط دو روتر میکروتیک را با IPIP Tunnel برقرار کنیم .
[تصویر:  Mikrotik-ipip1.png]
تنظیمات رو تر ۱ :

کد:
interface ipip  add local-address=20.0.0.1 remote-address=20.0.0.2
interface ipip  print
Flags X  disabled, R - running      NAME       MTU     LOCAL-ADDRESS    REMOTE-ADDRESS      
 0                                 X  ipip 1    1480      20.0.0.1         20.0.0.2  


ست کردن ip در سر تانل :
کد:
ip address add address=10.0.0.1 netmask=255.255.255.0 interface= ipip1  


تنظیمات روتر ۲ :

کد:
interface ipip  add local-address=20.0.0.2 remote-address=20.0.0.1
interface ipip  print
Flags X  disabled, R - running      NAME       MTU     LOCAL-ADDRESS    REMOTE-ADDRESS    
 0                                 X  ipip 1    1480      20.0.0.2         20.0.0.1  


ست کردن ip در سر تانل :
کد:
ip address add address=10.0.0.2 netmask=255.255.255.0 interface= ipip1  


راه اندازی تانل Gre در میکروتیک
با توجه به شکل زیر میخواهیم ارتباط دو روتر میکروتیک را که از طریق اینترنت یکدیگر را می‌بینند را با Gre-Tunnel برقرارکنیم .
[تصویر:  Mikrotik-gre1.png]

تنظیمات رو تر ۱ :

کد:
interface gre  add local-address=20.0.0.1 remote-address=20.0.0.2
interface gre  print
Flags X  disabled, R - running      NAME       MTU     LOCAL-ADDRESS    REMOTE-ADDRESS      
 0                                 X  gre 1    1480      20.0.0.1         20.0.0.2  


ست کردن ip در سر تانل :
کد:
ip address add address=10.0.0.1 netmask=255.255.255.0 interface= gre 1  


تنظیمات روتر ۲ :

کد:
interface gre  add local-address=20.0.0.2 remote-address=20.0.0.1
interface gre  print
Flags X  disabled, R - running      NAME       MTU     LOCAL-ADDRESS    REMOTE-ADDRESS    
 0                                 X  gre 1    1480      20.0.0.2         20.0.0.1  


ست کردن ip در سر تانل :
کد:
ip address add address=10.0.0.2 netmask=255.255.255.0 interface= gre 1  

چاپ این مطلب

  راه اندازی Web Analyzer در IBSng A1.24
ارسال کننده: sina - 2018/02/18، 06:02 PM - انجمن: آموزش ها - بدون پاسخ

در این آموزش راه اندازی Web Analyzer در IBSng  Centos 6 می پردازیم . برای راه اندازی ابتدا باید کش سرور اسکوید (Squid) بر روی سروری که IBSng نصب نمی باشد نصب گردد .
این آموزش در حالتی در نظر گرفته شده است که RAS سرور میکروتیک باشد .
یک نکته باید در نظر گرفت که شما باید کانفیگ رو طوری انجام بدین که درخواست کلاینت ها یا به عبارتی سورس ادرس با همون ip که از pool شما چه در pppoe چه در VPN هست به سمت اسکوید فرستاده بشه.
برای همین میایم IBSng رو مستقل به یکی دیگه از اینترفیس های میکروتیک متصل می کنیم .
برای مثال رنج کلاینت ها در pool میکروتیک 192.168.100.0/24 است .
به IBSng یا به عبارتی سیستم عامل لینوکس IP 192.168.20.2/24 را می دهیم ،در اینترفیس دیگه میکروتیک به IBSng به آن متصل است IP 192.168.20.1/24 را قرار می دهیم .لازم به ذکر است در سیستم عامل لینوکس گتوی باید میکروتیک باشد.
در میکروتیک
ابتدا در فایروال تب منگل یک قانون مینوسیم تا درخواست های وب ( پورت 80 ) در میکروتیک مارک دار کند و مارک هر درخواست را Squid قرار دهد .

کد:
/ip firewall mangle
add action=mark-routing chain=prerouting comment="" disabled=no dst-port=80 new-routing-mark=Squid passthrough=yes protocol=tcp src-address=192.168.100.0/24

رنج IP کاربران و اکانتینگ رو در NAT قرار میدیدم تا هم اسکوید و هم کاربران اینترنت داشته باشند .

کد:
/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no src-address=192.168.20.2
add action=masquerade chain=srcnat comment="" disabled=no src-address=192.168.100.0/24

روت کردن ترافیک ارسالی به  اسکوید در میکروتیک  ، رنجی که قرار هست توسط اسکوید مانتور بشود و لاگ های وب سایت های باز دید شده ثبت شود را با روت به سمت سرور اسکوید ارسال می کنیم

کد:
/ip route
add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.20.2 routing-mark=Squid scope=30 target-scope=10

نکته : routing-mark در این قانون بسته هار را مانیتور میکند و سپس بسته های مربوط به هر قانون را از گتوی مربوطه هدایت می کند . در این قانون بسته ها با نام Squid شناسایی می شوند
در IBSng ( Centos)
ابتدا پکیج اسکوید رو نصب می کنید .

کد:
yum install squid
chkconfig squid on

بعد از نصب با دستور زیر فایل اصلی کانفیگ اسکوید را به نام دیگر تغییر دهید .
کد:
mv /etc/squid/squid.conf /etc/squid/squid.conf.bkp

سپس با دستور زیر فایل جدید را می سازیم . این عمل به منظور خلاصه تر شدن فایل کانفیگ انجام میگردد تا در کانفیگ اسکوید سردرگم نشوید .
کد:
grep -ve ^# -ve ^$ /etc/squid/squid.conf.bkp > /etc/squid/squid.conf

فایل squid.conf به شرح زیر تغییر بدید،اسکوید باید در مود transparent کانفیگ گردد .

کد:
acl manager proto cache_object
acl localhost src 127.0.0.1/32 ::1
acl to_localhost dst 127.0.0.0/8 0.0.0.0/32 ::1
acl localnet src 192.168.100.0/24 # RFC1918 possible internal network
acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT
http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localnet
http_access allow localhost
http_access deny all
http_port 3128 transparent
coredump_dir /var/spool/squid
refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern -i (/cgi-bin/|\?) 0     0%      0
refresh_pattern .               0       20%     4320

squid analyzer در IBSng رو اجرا و حالت Auto رو انتخاب کنید
کد:
usr/local/IBSng/addons/squid_analyzer/setup.sh

نکته :
اگر به صورت Auto اجرا نشد از حالت دستی استفاده کنید

کد:
cd /usr/local/IBSng/addons/squid_analyzer/
cp init.d/squid_analyzer /etc/init.d
chkconfig --add squid_analyzer
chkconfig squid_analyzer on
cd /usr/local/IBSng/addons/squid_analyzer/logrotate.d
cp squid /etc/logrotate.d
cp squid_analyzer /etc/logrotate.d
حالا سرویس های مورد نظر را استارت کنید

کد:
/etc/init.d/squid_analyzer start
/etc/init.d/squid start

اعمال قوانین بر روی iptables لینوکس به جهت استفاده اسکوید و کلاینت از اینترنت در سرور لینوکس

کد:
iptables -t nat -A POSTROUTING -s 192.168.100.0/24 -j MASQUERADE
iptables -A PREROUTING -t nat -s 192.168.100.0/24 -p tcp --dport 80 -j REDIRECT --to-port 3128

حتما این ip forward در لینوکس رو روشن کنید
کد:
echo 1 > /proc/sys/net/ipv4/ip_forward

در صورتی که مطالب سایت برای شما مفید بوده است و نیاز به فیلم آموزش برای راه اندازی دارید شما می توانید از طریق لینک زیر از سایت حمایت کنید .

چاپ این مطلب

  آموزش نصب IBSng A1.24
ارسال کننده: sina - 2018/02/17، 09:24 AM - انجمن: آموزش ها - بدون پاسخ

با توجه به لزوم استفاده از اینترنت(Internet) در سازمان ها ، ارگانها ، شرکتهاو دانشگاهها و همچنین حساسیت در نحوه استفاده صحیح از این شبکه جهانی و

همچنین جلوگیری از پایین آمدن سرعت اینترنت در شبکه که گاها مشاهده شده بعلت عدم وجود نرم افزارمدیریتی خوب و کارآمد، این مهم انجام نپذیرفته و باعث
بروز برخی اشکالات در شبکه های داخلی شده ،لذا این شرکت جهت رفع مشکل ،سیستم اکانتینگ IBSng راباقابلیتهای ذیل ارائه نموده
Bandwidth Manager(مدیریت پهنای باند)
Web analyzer(مشاهده وب سایتهای بازدید شده Squid )
Web Filtering (فیلترینگ سایتها Squid )
Cache Server( افزایش دهنده سرعت اینترنت Squid )
Cacti( مانیتورینگ سیستم ها )
Vpn Server(امکان آسان اتصال به اینترنت)

قابلیت های نرم افزار
  1. گزارش گیری از سایتها
  2. ارائه گزارشات از تمام سخت افزار های شبکه
  3. حسابداري سرویس Dialup
  4. حسابداري کاربرانLAN
  5. حسابداري کلیه سرویس ها به صورت یکپارچه
  6. قابليت دسترسي از طريق وب به تمام قسمتهاي برنامه (Web Based)
  7. Username، Passwordو شماره سریال توليد شده به صورت فايل CSVو PDF، به منظور چاپ و توليد کارتهاي اعتباري
  8. یک محدوده ساعت مشخص از شبانه روز
  9. روزهای خاصی از هفته
  10. تعیین زمان انقضاء اعتبار کاربر
  11. مسدود کردن حساب کاربران غير مجاز
  12. تعیین تعداد Sessionهاي همزمان هر مشترک
  13. حذف گروهی کاربران
  14. کاهش یا افزایش و یا تعیین اعتبار برای گروهی کاربران
  15. قطع اتصال کاربران Onlineبه صورت تکی
  16. ارائه گزارشات متنوع و مفید از کاربران Online، همراه با جزئیات اتصال همانند CallerID، MAC Address و IP Address
  17. امکان ارائه گزارش از دلیل اتصالات ناموفق کاربران
  18. اتصال کاربران LAN/WLANتوسط تکنیکهای(VPN (PPTPو Persistent LANبر اساس تنظیم،MACAddress، IP Address
  19. امکان گزارش گیری و جستجوی کاربران بر اساس MAC Addressو IP Address
  20. اختصاص یک محدوده IPبه کاربران (تعریف IPPool‍)
  21. قابلیت ایجاد Username ترکیبی و ترتیبی برای کاربران
  22. مشاهده ي كاربراني كه بيشترين حجم دانلود را دارند
  23. گزارشگيري از وب سايتهاي مشاهده شده كل سيستم ويا براي هركاربر بر اساس بازه ي زماني دلخواه
  24. امكان تعريف چندين اپراتور براي مديريت كاربران تحت نظارت با اعمال محدوديت هاي دلخواه براي آنها
  25. امكان lockكاربران و نيز unlockبه راحتي
  26. امكان اتصال كاربران به شبكه با استفاده از ibsng dialer
  27. امكان پشتيبان گيري ازاطلاعات در هر لحظه از زمان بر روي سرور
  28. امكان importو exportكردن نام كاربري و كلمه ي عبور
  29. قابلیت ایجاد Passwordتصادفی، ترکیبی و ترتیبی برای کاربران
این برنامه از ترکیب دو زبان برنامه نویس پایتون و php نوشته شده که بر روی سیستم عامل های لینوکس قابل نصب است.
این برنامه تحت وب بوده و از وب سرور آپاچ استفاده میکند.
با توجه به توضیحات بالا در مورد کلایت برنامه میرسیم به آموزش نصب برنامه.

ابتدا برنامه رو داخل سرور خود دانلود کنید.
کد:
wget http://www.paraserver.net/dl/soft/IBSng-A1.24.tar.bz2

سپس با دستور زیر از حالت زیپ خارج می کنید .
کد:
tar -xjf IBSng-A1.24.tar.bz2

با دستور زیر پوشه از زیپ خارج شده را به مسیر ذکر شده انتقال می دهید .
کد:
cp -Rf IBSng /usr/local

سپس سرویس های مورد استفاده نرم افزارو نصب میکنید اگر شما بر روی شبکه لوکال تصمیم به نصب گرفایت باید سرور شما دست رسی اینترنت داشته باشد .
کد:
yum install httpd php postgresql postgresql-server postgresql-python perl -y

سرویس دیتا بیس رو استارت می کنید .
کد:
service postgresql start

با دستور nano فایل دیتابیس رو جهت ویرایش باز می کنید .
کد:
nano /var/lib/pgsql/data/pg_hba.conf

خط زیر رو در انتهای فایل اضافه می کنید و با میان بر Ctrl+x سپس y فایل رو ذخیره می کنید و از ادیتور خارج می شوید .
کد:
local IBSng ibs trust

سرویس دیتابیس رو مجداد رستات می کنید .
کد:
service postgresql restart

وارد دیتا بیس میشیم تا دیتابیس و یوزر های مربوطه رو بسازید .
کد:
su - postgres

با دستور زیر دیتابیس با نام IBSng ساخته می شود .
کد:
createdb IBSng

جهت دست رسی به دیتابیس یوزر ibs ساخته می شود .
کد:
createuser ibs

زبان دیتابیس رو با زبان IBSng یک سان میکنید .
کد:
createlang plpgsql IBSng

از محیط دیتابیس خارج می شید .
کد:
exit

وب سرویس آپاچ رو استارت می کنید .
کد:
service httpd start

فایل نصب نرم افراو اجرا می کنید .
کد:
/usr/local/IBSng/scripts/setup.py

به ترتیب شماره های زیر را جهت نصب و ادامه نصب انتخاب می کنید .
کد:
1  Install
2  Test DB Connection and continue
2  Compile Configuration and continue
1  Import Tables And Continue
admin password
1  Copy ibs.conf to '/etc/httpd/conf.d'
2  Chown apache directories to 'apache'
5  Continue
1  Copy Logrotate Conf to /etc/logrotate.d
3  Continue
1  Copy Redhat init file to /etc/init.d
2  Set IBSng to start on reboot
b  Back to main menu
x  Exit

مجدا سرویس آپاچ رو جهت اعمال تغییرات ریلود می کنید .
کد:
service httpd reload

سروی اکانتینگ رو استارت می کنید .
کد:
service IBSng start

سرویس اکانتینگ رو در استارت آپ سیستم عامل قرار می دهید .
کد:
chkconfig IBSng on

سرویس دیتا بیس رو در استارت آپ سیستم عامل قرار می دهید .
کد:
chkconfig postgresql on

سرویس وب سرور رو در استارت آپ قرار می دهید .
کد:
chkconfig httpd on

هر گونه پرسش و پاسخ در این قسمت



فایل‌(های) پیوست شده
.zip   IBSng-A1.24.tar.zip (اندازه: 1/5 MB / تعداد دفعات دریافت: 0)
چاپ این مطلب