امتیاز موضوع:
  • 0 رأی - میانگین امتیازات: 0
  • 1
  • 2
  • 3
  • 4
  • 5
PPTP-Mikrotik
#1
برای استفاده از Mikrotik به عنوان VPN ras مراحل زیر را انجام می دهیم:
config کردن Mikrotik به عنوان VPN سرور
برای این کار از دستورات زیر استفاده می کنیم:

کد:
/interface pptp-server server set enabled=yes max-mtu=1488 max-mru=1488 authentication=chap,mschap1,mschap2,pap keepalive-timeout=10 default-profile=default
/ppp profile set 0 local-address=<Mikrotik ip address> change-tcp-mss=yes
/ip firewall mangle add chain=forward action=change-mss new-mss=1300 tcp-flags=syn protocol=tcp


config کردن Mikrotik برای ارتباط با IBSng
این کار با دستورات زیر انجام می شود:

کد:
/ppp aaa set use-radius=yes accounting=yes interim-update=60
/radius add address="IBSng server IP" accounting-port=1813 authentication-port=1812 secret="prefered secret" service=ppp,  timeout=1000
/radius incoming set accept=yes
/radius incoming set port=1700


تنظیم routing ها
NAT کردن ip های assign شده به user ها:
کد:
iptables -t nat -A POSTROUTING -s <IP range> -j MASQUERADE


تنظیم route برگشت:
کد:
route add -net <IP range> gw <Mikrotik's IP>
پاسخ


پرش به انجمن:


کاربرانِ درحال بازدید از این موضوع: 2 مهمان